No components marked as affected
Resolved
This issue is resolved
Monitoring
We've identified the cause and are rolling out a fix; some jobs may still see delays while we work through the backlog.
Investigating
We are aware of of elevated video translate latency and failure rate, we are working on mitigating it